Posts

WiFI SDIO Broadcom, Infineon 43455, Notes to learn from for FreeBSD / GhostBSD-Arm64

Image
WiFI SDIO Broadcom, Infineon 43455,  Notes to learn from for FreeBSD / GhostBSD-Arm64 https://wiki.gentoo.org/wiki/Raspberry_Pi4_64_Bit_Install#WiFi WiFi WiFi needs three firmware files from in /lib/firmware/brcm/ : brcmfmac43455-sdio.bin brcmfmac43455-sdio.clm_blob brcmfmac43455-sdio.txt Which is almost but not quite the same as the Pi3. The catch is in brcmfmac43455-sdio.txt where grep boardflags3 produces different results for the Pi3 and Pi4 files. The Pi4 version returns boardflags3=0x44200100 The Pi3 version returns boardflags3=0x48200100 With the wrong brcmfmac43455-sdio.txt file, bluetooth will work but not WiFi. These files, including the Pi 4 version of above file, are found in sys-firmware/raspberrypi-wifi-ucode , to install it you'll also need to install sys-kernel/linux-firmware with the savedconfig USE flag and remove the conflicting files from the saved configuration, and then re-emerge linux-firmware to apply the new de-conflicted saved configuration: /

Create a GhostBSD USB SSD 500GB or larger size

  Create a GhostBSD USB SSD 500GB or larger size This is source file I used.  You have to set global environment variable DISK1 in fish shell  set -gx DISK1 /dev/da0 cat  ./create_ssd_GhostBSD.sh root@omid-ghostbsd-pc /h/o/ssd_test# cat ./create_ssd_Ghostbsd_da1.sh  #!/bin/sh set -e set -x echo " ${DISK1} <--- This is the DISK1 environmental variable, set example: DISK1=/dev/da1; export DISK1 " echo " Made for a 500GB size USB to NVMe style SSD disk style SSD disk  " # echo "If da1 already exists,  use  gpart destroy -F da1  or gpart destroy -F ${DISK1} to clean of partitions on da1 " sleep 6 gpart list ${DISK1} gpart status ${DISK1} gpart show -lp ${DISK1} echo "  create a GPT scheme on ${DISK1} hit ctrl-C to exit. " # test if geom disk list da1  ,  then gpart destroy -F ${DISK1} if gpart status ${DISK1} ; then    gpart show -lp ${DISK1}    echo " Type Ctrl-C  NOW!  to stop destroy ${DISK1}  "    sleep 6    gpart destroy -F ${DISK1}

How to Create and Distribute my own FreeBSD package

 How to Create and Distribute my own FreeBSD package Vermaden has an Excellent article on using FreeBSD Poudriere and setting up NGinx to serve packages.   I wrote a document about learning Packaging,  " Dead Simple Packaging How To "  ' for FreeBSD Dummies' http://ghostbsdarm64.hopto.org/packages/  Dead_Simple_Binary_Packaging_How_To_10 _6C.pdf   PDF Document describing How to Create and Distribute my own FreeBSD package for you to read and learn.  I placed some diagrams in there, to make it easy to understand. http://ghostbsdarm64.hopto.org/packages   my NGINX webserver directory for serving ghostbsd-arm64 packages to the world. http://ghostbsdarm64.hopto.org/packages/Guru_pdf_abiword.tar.gz   Here is source Abiword files for GURU shell script and python application  "Generate_User_Report_for_Upload" application for FreeBSD and GhostBSD. Contents of the file Guru_pdf_abiword.tar.gz $ tar tvf Guru*.gz -rw-r--r-- fred/fred    710312 2023-07-04 17:30 ./Guru/

Sound? How do I hear thee? NOT! Let me count the ways. The sounds of silence.

Image
Sound?  How do I hear thee? NOT!  Let me count the ways. The sounds of silence.   From electrical field to mechanical air vibrations to my ear. How do you set the sound to work on GhostBSD/FreeBSD ?  As a new user you have:   NO IDEA WHAT TO DO! What cryptic incantation do issue to appease the great monster in the VOID beyond my simple imagination.  On what sequence of characters to type into the command line? After having working  Ghos tBSD 23 with sound.  I upgraded to GhostBSD 24.01.01 with the GUI app Update-Station.   This app deleted some software apps and then re-installed the newer version of that software library and applications. virtual_oss_cmd /dev/dsp.ctl -f /dev/dsp1 That is the one SINGLE command line I issued to just magically turn on the sound.  Yes I had spent about 8 hours of time 3 months ago, trying to use USB Headphones on my laptop and on my Raspberry Pi 4B running both FreeBSD 14.0-RELEASE and GhostBSD-Arm64 14.0-STABLE to hear sounds from a test using MPG123 (

Compile gdb for aarch64 target to use with MX-Linux. Later compile to use with FreeBSD or GhostBSD-Arm64

Compile gdb for aarch64 target REMOTE Debugging with EmCraft https://www.emcraft.com/som/imx-8m/remote-debugging-with-gdb   Here I found a forum post at forums.raspberrypi.com and a shell script file See my post 2nd about aarch64  https://forums.raspberrypi.com/viewtopic.php?p=2200136&hilit=gdb#p2200136 The first forum post has many useful links and notes. I got a debug probe, here's a bash script to build GDB for ARM   https://forums.raspberrypi.com/viewtopic.php?t=364475  

Tigard FT232H Board connectons to a Raspberry Pi 4B for GDB and OpenOCD operation

Image
 Tigard FT232H Board connectons to a Raspberry Pi 4B for GDB and OpenOCD operation https://www.crowdsupply.com https://www.crowdsupply.com/press/tigard   Tigard Board Press Release https://www.crowdsupply.com/securinghw/tigard   Securing Hardware Github directions https://github.com/tigard-tools/tigard    Github hookup directions and source code https://www.electronics-lab.com/tigard-is-here-to-bust-open-any-embedded-physical-interface-you-can-find/   Electronics Lab short write up with GREAT Photo of Tigard Board. https://github.com/tigard-tools/tigard#jtag-debug-on-jtag-or-cortex-header   Github Jtag setup of Tigard board. ( city of Tigard Oregon ) https://embeddedsandbox.com/wordpress/my-raspberry-pi-4-jtag-setup-part-1-introduction/   Part 1 Software, of My Raspberry Pi 4 JTAG setup https://embeddedsandbox.com/wordpress/my-raspberry-pi-4-jtag-setup-part-2-the-hardware-setup/   Part 2 Hardware, of My Raspberry Pi 4 JTAG setup https://pinout.xyz/pinout/jtag   Raspi 4B JTAG pinout 40

Uart3 Serial Port, How to locate the source code used by FreeBSD / GhostBSD-Arm64

Image
 Uart3 Serial Port,  How to locate the source code used by FreeBSD / GhostBSD-Arm64 Edit the file /etc/rc.conf  and  add the bash execution line 'set -x'  This will produce verbose output from  'make buildkernel KERNCONF=GENERIC-VCHIC   -DNO_CLEAN Issue the  'make buildkernel' command and direct stdout & stderr to a file. make buildkernel KERNCONF=GENERIC-VCHIQ -DNO_CLEAN > BRCM64_GENERIC-VCHIQ.txt 2>&1  later you can run make installkernel KERNCONF=GENERIC-VCHIQ ===> wlan_tkip (install) install -T release -o root -g wheel -m 555   wlan_tkip.ko /boot/kernel/ install -T dbg -o root -g wheel -m 555   wlan_tkip.ko.debug /usr/lib/debug/boot/kernel/ ===> wlan_wep (install) install -T release -o root -g wheel -m 555   wlan_wep.ko /boot/kernel/ install -T dbg -o root -g wheel -m 555   wlan_wep.ko.debug /usr/lib/debug/boot/kernel/ ===> wlan_xauth (install) install -T release -o root -g wheel -m 555   wlan_xauth.ko /boot/kernel/ install -T dbg -o root