Posts

BSD CAFE and me a Raspberry Pi 4B running GhostBSD

 https://BSD.CAFE and me a Raspberry Pi 4B running GhostBSD    Comments about BSD CAFE on BSDNOWTV telegram desktop conversation. bsd.cafe   https://www.youtube.com/@BSDCafe   YouTube channel for BSD Cafe  Stefano Marinelli, [10/13/24 3:36 AM] This is a great idea - and I have a spare Raspberry PI 4 with 8 GB of ram, so I can test it. Stefano Marinelli, [10/13/24 3:37 AM] I thinkt the BSD Cafe can give you the help and feedback of many BSD users, so I think you should join and share your ideas/projects Fred Finster, [10/13/24 7:20 AM] Thank you for this answer, Stefano.   The image is rough, and the NTPD daemon seems to hang up the shell script from completing.  Once the usb flash drive stick is written ( created) and booted , then you can add a usb ssd to have a DIY ( do it yourself )  workstation. Fred Finster, [10/13/24 7:21 AM] write_freebsd_image_dd_to_,da1.sh  shell script is the place to start. https://ghostbsd-arm64.blogspot.com/2023/12/how-to-install-ghostbsd-arm64-into-usb.

ue0 USB cable tether cell phone internet to Raspberry Pi Arm64 running FreeBSD / GhostBSD

 ue0   USB cable tether cell phone internet to Raspberry Pi Arm64 running FreeBSd / GhostBSD https://forums.freebsd.org/threads/usb-tethering-detected-and-up-but-no-internet.88441/#post-659712   Hope this helps to get internet connection from Android Cell phone to your Raspberry Pi  running FreeBSD or GhostBSD-Arm64    

The Magic of RISC-V Vector Processing; Instructional Video

Image
The Magic of RISC-V Vector Processing   https://www.youtube.com/watch?v=Ozj_xU0rSyY     139,406 views May 30, 2024 The 1.0 RISC-V Vector Specification is now Ratified, and the first pieces of silicon using the new spec are starting to hit the shelves. I go over the utility of Vector Instructions, why you would want them, why you should care, and how to use them in raw assembly code! We also touch on some complex computer engineering topics like Vector Length Agnosticism. By the end of this video, you'll understand why this is such an exciting time in computing history! Note: This video is not sponsored, I just think the K230 is an interesting chip.  RISC-V Official 1.0 Vector Spec: https://github.com/riscv/riscv-v-spec...    Follow LaurieWired on Social Media: ► https://linktr.ee/lauriewired   With this information available to read.  We can select a RiscV SBC to practice with.  Testing assem

NetBSD aarch64 10.0 install on Raspberry Pi 4B, wahoo it works, Fred!

Image
NetBSD aarch64 10.0  install on Raspberry Pi 4B,   wahoo it works, Fred!  Well, this is a good accomplishment for May 7th 2024. Installing NetBSD 10.0 on a Raspberry Pi 4B with 8Gigs.     May 7th is also my son Conner Louis Tilley:    7lbs, 7 ounces, born on the 7th of May.  My little triple 7 ( in the next month June of 1995 Boeing announced the Triple Seven, 777 model Dreamliner Airplane ) arrived into my Life,  my son,  Connor Louis Tilley. https://www.facebook.com/connor.tilley.2903   He is a video games developer with Amazon Games When did the Boeing Triple Seven, 777 come out? The Boeing 777 is a family of wide-body twin-engine commercial jet aircraft with variants for both passenger and cargo transportation. The 777 was first flown on June 12, 1994, and commercial service commenced on June 7, 1995. So there are 2 objectives to accomplish when setting up NetBSD 10.0 for a Raspberry Pi 4B.   Download and  write  arm64.img into a USB Flash drive stick.  Download Paul Bartard's

PXE aarch64 TFTp boot a Raspberry Pi 4B over the network, May 5 2024

 PXE aarch64 TFTp boot a Raspberry Pi 4B over the network, May 5 2024   PXE:TFTPd Setup   This is one of the easiest pieces to get working. mkdir /tftpboot .  zfs list; zfs create -o compress=off arm64pool/tftpboot Uncomment the tftp line in /etc/inetd.conf . tftp    dgram   udp     wait    root    /usr/libexec/tftpd      tftpd -l -s /tftpboot # enable the ftp server ftp    stream  tcp     nowait  root    /usr/libexec/ftpd       ftpd -l Add inetd_enable="YES" to your /etc/rc.conf. Run /etc/rc.d/inetd start . Now that the server is working, we need the boot loader that will be served via TFTP to the PXE loader on your machine. for x86_64, maybe for aarch64 needs a different pxeboot file and file name?? cp /sys/boot/i386/pxeldr/pxeboot /tftpboot  zfs create  example root@Ghost14-selfbuilt-rpi4B-nginx-tst1:~ # zfs create -P -o quota=5G -o mountpoint=/tftpboot arm64pool/tftpboot create    arm64pool/tftpboot property    quota    5G property    mountpoint    /tftpboot zfs set com

WiFI SDIO Broadcom, Infineon 43455, Notes to learn from for FreeBSD / GhostBSD-Arm64

Image
WiFI SDIO Broadcom, Infineon 43455,  Notes to learn from for FreeBSD / GhostBSD-Arm64 https://wiki.gentoo.org/wiki/Raspberry_Pi4_64_Bit_Install#WiFi WiFi WiFi needs three firmware files from in /lib/firmware/brcm/ : brcmfmac43455-sdio.bin brcmfmac43455-sdio.clm_blob brcmfmac43455-sdio.txt Which is almost but not quite the same as the Pi3. The catch is in brcmfmac43455-sdio.txt where grep boardflags3 produces different results for the Pi3 and Pi4 files. The Pi4 version returns boardflags3=0x44200100 The Pi3 version returns boardflags3=0x48200100 With the wrong brcmfmac43455-sdio.txt file, bluetooth will work but not WiFi. These files, including the Pi 4 version of above file, are found in sys-firmware/raspberrypi-wifi-ucode , to install it you'll also need to install sys-kernel/linux-firmware with the savedconfig USE flag and remove the conflicting files from the saved configuration, and then re-emerge linux-firmware to apply the new de-conflicted saved configuration: /

Create a GhostBSD USB SSD 500GB or larger size

Image
  Create a GhostBSD USB SSD 500GB or larger size This is source file I used.  You have to set global environment variable DISK1 in fish shell  set -gx DISK1 /dev/da0 cat  ./create_ssd_GhostBSD.sh root@omid-ghostbsd-pc /h/o/ssd_test# cat ./create_ssd_Ghostbsd_da1.sh  #!/bin/sh set -e set -x echo " ${DISK1} <--- This is the DISK1 environmental variable, set example: DISK1=/dev/da1; export DISK1 " echo " Made for a 500GB size USB to NVMe style SSD disk style SSD disk  " # echo "If da1 already exists,  use  gpart destroy -F da1  or gpart destroy -F ${DISK1} to clean of partitions on da1 " sleep 6 gpart list ${DISK1} gpart status ${DISK1} gpart show -lp ${DISK1} echo "  create a GPT scheme on ${DISK1} hit ctrl-C to exit. " # test if geom disk list da1  ,  then gpart destroy -F ${DISK1} if gpart status ${DISK1} ; then    gpart show -lp ${DISK1}    echo " Type Ctrl-C  NOW!  to stop destroy ${DISK1}  "    sleep 6    gpart destroy -F ${DISK1}